Compton Organs still in churches?

This forum is dedicated to discussion about Compton Melotones and Electrones

Re: Compton Organs still in churches?

Postby mcmurdo » Sun Dec 03, 2017 5:32 pm

I'm glad it wasn't put in the skip then. I was sent to investigate a loud 'pop' that would happen every couple of minutes or so but only when it was playing. Not knowing the first thing about them, I ascertained it wasn't a dry joint and then backed off. I was rather surprised it was still in daily use, despite, the organist said, the pops making the children in the congrgation cry. It had already had new speakers, I'm guessing at the time of the amp change. I'm sticking to Hammonds!
mcmurdo
 
Posts: 11
Joined: Sat Sep 09, 2017 2:59 pm

Re: Compton Organs still in churches?

Postby Lucien Nunes » Wed Dec 06, 2017 5:17 pm

The pops were probably caused by rotor discharges / flashovers due to an O/C rotor leak resistance. This took the form of a carbon (pencil) line joining the active part of the rotor coating to the hub. They seem to range from tens to hundreds of megs without causing any problems, but if they go open entirely the rotor can slowly charge by induction and triboelectric generation until it is at a high enough voltage to flash over. I have seen some generators rebuilt by Fred Allen, in which a 1/8W 10M resistor is epoxied into a drilling near the hub, the ends being linked to the hub and active areas by conductive paint. This seems a much more stable solution although such small ready-made resistors weren't available first time around.

The other cause of pops or 'machine gunning' in a Compton is actual contact between rotor and stator, either due to peeled fragments of coating standing proud of the surface, or tin whiskers forming. This is quite prevalent on cinema Melotones - wee see it a lot at Southampton which often sits idle for months without the Melo being run. The next time it is powered up there will be a fresh crop of whiskers reaching out for the rotor and producing the characteristic crackle in time with the rotor rotation until they have broken away and fallen out. I like to give it a blast with compressed air and let it run with the covers off for a while, so that they can be ejected radially without churning in the slipstream and further fragmenting inside the generator.
Black was always meant to be a phase. The neutral phase.
Lucien Nunes
 
Posts: 320
Joined: Fri Apr 18, 2008 12:26 am

Re: Compton Organs still in churches?

Postby highlandelectrone » Thu Dec 07, 2017 1:13 pm

The 347 which we had at school (this would have been late 70's) had a habit of emitting loud bangs from time to time, which were usually down to the output valves arcing. The chap who normally serviced it would change them and then it would be fine for months. It would happen again though after some time - I now suspect that the HT was running way too high for some reason -sadly the instrument is long gone so there is no way of telling now!
highlandelectrone
 
Posts: 16
Joined: Sun Jul 03, 2011 11:36 am

Re: Compton Organs still in churches?

Postby mcmurdo » Mon Dec 11, 2017 10:22 pm

It did sound like a static pop. Not the output valves..it didnt have any. I have a feeling I spoke to Compton Service about it at the time and they said it would probably be a problem inside one of the generators.
I did get a nice few tunes out of it in the meantime.
mcmurdo
 
Posts: 11
Joined: Sat Sep 09, 2017 2:59 pm

Previous

Return to Compton Electrones

Who is online

Users browsing this forum: No registered users and 1 guest

cron